Post Sun Jan 09, 2011 6:22 am

Need Help! Problem with external HDD and emulator

I have this problem that happened twice. I have my Seagate External usb drive, 250 gig, set up to where I have my roms for emulators and a wbfs folder for wii games I ripped onto the hard drive. The external drive is all formatted to FAT 32. Anyways, it was working well until I went to play the Game Boy Advance emulator. After my daughter was playing a game and we went to stop the game, it went to automatically save the game. When I tried to load another rom, it said error opening directory. Now..all of my roms and wbfs data on my hard drive are not visible or accessible, and it only shows the app folder and a weird file by the name QOOABGPH.o I tried deleting that file but it says it cannot be found in the directory. When I click on properties, it shows that the space of my roms and wii games are still on the drive, but like I said they are invisible and I don't know how to correct this. Any pointers?? Also, I had the GBA emulator to save the game to the usb drive in the save folder of the roms. Do you think that is what caused this? This has happened to me twice now and I would rather not have to reformat the drive and start over for this to happen again. Please help!! Thanks!